Inpossible to sync the LXR with my DAW with Midi In/Out, and a led problem !
  • Hello,

    Everything is cool with the LXR but !

    When i sync the LXR with USB midi, there is no problem, everything is working as well !, but the led for the first bass drum part, don't work anymore ! i checked around, but everything looks fine. It don,t work only when i plug the usb !

    Also, impossible for me to sync the LXR with the midi ports ! i used a lot of configuration possible, but can't use it.. any suggestion ?
  • regarding the LED problem. Have you put tape or a piece of paper between the USB socket and the 2 resistors below it?

    midi playback over the normal MIDI ports is possible?
    Just to be sure your unit is receiving midi signals at all.
  • i have had no problem with normal midi din. yesterday i got to try the external shuffle and that too is working as expected.
    have you tried with another device or midi interface? have you set the channel to something other than zero?
  • Hey, 

    Freshly built LXR here and I think I have encountered the same problem as Lamouette. I'm running version 0.23. 
    I have tried saving the settings with bpm 0 so when it boots up it should sync to external clock, however nothing happens. 
    I noticed that if I set the bpm to internal clock at bootup (ie 120), hit play and later set the bpm to 0 it will sync fine. If I don't hit play before setting bpm to 0 the sync won't work.

    Besides that; great machine! :) 



  • I've been having issues with midi tempo with MIDI over USB on my laptop running OSX. I'm trying to sync with Ableton via a GM5 USB midi device, and the LXR is running at almost double tempo and eventually it ends up at max tempo, blinkenlights and all. However, MIDI note trigger via Launchpad or Korg Nanokey works fine. I have the same issue using Numerology. I've also had double triggers as well, it might be something with my setup. MIDI via MIDI in works fine though.
  • @Julian :

    yes, i put some tape on the usb, but i will recheck that tommorow.

    For the midi, nothing seems to work from the midi ports, i will check if i can do something with tb323 method.
  • @FreshPants Is it possible that you have a MIDI loop?
    does this also happen when you don't conect the MIDI out from the LXR to the computer?
    I will try to add local off and MIDI clock out on/off options to the settings menu in a future version.
  • @Julian

    I probably do have a midi loop somewhere. I've disable the usb MIDI out on the LXR from the Ableton side, but the tempo issues still exist. I haven't explored the MIDI out to the computer yet. I'll try that and see if I get the same behavior as with the USB MIDI.

    Local on/off would be great!

    Thx for the response.
  • the problem there is that midi clock is a global midi message, not bound to a channel.
    At the moment the LXR is transmitting it's own midi clock, even when it's set to external sync.

    I hope to fix this in the next firmware version!
  • Hmm... Different kind of MIDI loop when using the DIN connectors. Not the crazy tempo thing, but more of quick double note trigger(slight MIDI latency?). It might also be Ableton, as I tried again with MIDI over USB, and if I double click the stop button, this resets the LXR tempo and things work as normal. I think either Ableton is sending something else along with the start/stop, or the LXR is receiving whatever Ableton sends during start/stop that affects the tempo.

    All this USB sync stuff aside, LXR is still a brilliant piece of kit and I want to say thanks for such an awesome machine!
  • I'm really glad you like it!

    I will try to sync my unit here with ableton.
    Should be an easy fix.

    I will be on holliday untill the 18th and then it is firmware time. I just reduced my dayjob hours drastically :))
  • Enjoy your holiday!

    BTW, the sync issues I had were just the start/stop, the pattern was one programmed on the LXR, not MIDI from Ableton.
  • so the MIDI start/stop messages are executed even when the LXR is not set to external sync?
  • Oh sorry, it is set to external sync. The problem occurs with USB MIDI and a pattern programmed into LXR with Ableton sending clock start/stop.
  • @FreshPants, If I'm understanding correctly, this may be similar to what I've run into when syncing the LXR to Ableton (using MIDI, not USB).  A double stop is necessary before starting, otherwise it won't start the LXR playing.
  • Hi all - I know Julian's on holiday so posting where some people have had the same issues I've been having, or similar.  I get slightly more than double speed play on LXR when sync'd to Octatrack via external MIDI via 5-pin cable.  Transport ie start/stop external control is still present and the tempo is affected, i.e. slows when I slow tempo on Octatrack - but stays more than twice as fast.

    I've reformatted SD card, reinstalled image etc.  Did think I had successfully updated to v0.23 as well but the display still says v0.21 when I boot up - are people getting v 0.23 on the screen? or was that not part of the update (serious question as I know was missed once before).

    Version 0.21 is fine by me but the racing tempo means I can't feed the Octatrack crazy FM loops in correct timing, obviously something to aim for - so any tips on slowing down my runaway LXR??


    Edit - even before I posted this (which was after a lot of faffing around) - I had a thought and put my LXR straight in front of the octatrack instead of after my Anushri - works fine now.  Now I am a bit stuck as don't think the MIDI out is working yet.... so how to trigger Anushri hmmm thought I'd post anyway in case anyone in same boat... happy bleeping
  • @retrig

    I've only had these issues with MIDI over USB. Regular DIN5 MIDI is working fine for me. Also receives MIDI clock from a MIDIAlf, lots of fun.
  • I will finish the batch 2 preparations (just finished building one of the new prototypes) then I will look into the firmware again. So probably next week.

    Can't explain the double speed at the moment. No midi loop?
  • for me - maybe it was a MIDI loop - only happened when my LXR was downstream from Anushri.  I am pretty clueless when it comes to MIDI & would be guessing what a MIDI loop is, obviously could google it but anyway I'm guessing it wasn't the LXR's fault at all.  
    Once the LXR will receive & then transmit MIDI clock from an external source, I'll put it first in line after my sequencer and then should avoid that happening...
    btw I must say Julian we are pretty prone to only posting about problems we are having... actually having lots of fun with LXR & very grateful for all your time!
    jk

  • hi all
    anyone got the LXR transmitting MIDI "thru" out of the non-in MIDI port yet?
    do you have to select anything in any menus?

    I'm more interested in triggering stuff downstream from LXR with my Octatrack (since don't have a patchbay) than using LXR MIDI triggers at the moment.

    thanks
    jk
  • just had a crash with my LXR

    scenario:

    was jamming with cirklon. cirklon as master clock, lxr was on 120 bpm (didn't mind, as I used the cirklon sequencer to sequence the lxr). when I set lxr to completely ccw (ext) whilst everything was running because I wanted to use rolls in sync, lxr only gave a neverending peeeeeeeeeeeeeeeeeeeep, no more drums. only restart solved it. tried it twice, everytime the same. 


    when lxr bpm is set to completely ccw (ext) and I start a session with cirklon (turn on everything, then press start on cirklon), lxr won't start its sequencer running. all my other gear does.


    I have only a problem in slave mode with lxr, otherwise all fine.

    does anyone else have this problem?

  • Sounds like the scenario I wrote about earlier.
    If you boot with bpm 120, press play and later set it to external it will work. ;)
  • yes... I couldn't swear this is a consistent thing - but I saved settings at 0 bpm so I could get straight to external control every time - but ended up finding that turning LXR on with a native bpm (e.g. 120), pressing play and only then going to 0 bpm, made for more reliable external control - otherwise LXR didn't always start.
    However I am a bit prone to defaulting to a work-around rather than getting to the bottom of problems by thought!!  
    jk
  • I will have a closer look at this problem once I handled the preorders.
    so just to recap:
    - It works when booting with 120 BPM and setting it to 0 manually AFTER hitting play.
    - it works not if the default BPM after bootup is set to 0 right away?

  • @julian: Exactly. I have tried with a midipal as clock source just FYI.
  • hi, just to jump in here, too. today i tried to connect my lxr to my analog four. it didnt work to sync the analog four using the lxr. and the other way round (which i'd prefer) doesnt work, too. 
  • my cirklon starts when hitting play on LXR. perhaps something to set up in the menu of A4? did you try another sequencer to get it working?
  • yes, i tried it with my x0x and my electribes, too. those do it. i tried those to the lxr, and they didn't get it started, nor did they start by the lxr. strange
  • i found something even more interesting. when i unplug the audio outputs from the lxr i can start it by using external sync. as soon as i plug audio out it stops playing and is not able to get the sync.

    maybe this points to something in the firmware? i dunno
  • i'm looking into the sync issues at the moment.
    I already found the cause for the "set BPM to 0 before pressing the start button bug"
    Maybe someone is willing to beta test the fix... I'll build a test version later on today.
  • I'd test it... If you still look for a tester...
  • regarding your non starting sequencer-are you sure your midi io on the lxr is working?
    can you play instruments using a midi keyboard? or do you have some midi monitor software like 'midi ox' to makesure the LXR is sending something?
  • yes, i can play the drumsounds using the lxr. 

    at the moment i don't have a connection to my computer since i am trying to avoid it generally :) i tried other things as well, just to be sure its not the other component. but the x0x does trigger the elektron and the elektron triggers the x0x.
  • ok, tried midi-ox and it doesnt receive nor is it able to send sync from/to the lxr

    wait, another test after restart and now when i hit play in midi-ox, the lxr starts and immediately stops playing. as soon as i unplug the audio outs, it starts synced by midi-ox. just like with the other hardware. seems it definately has to do with those audio-outs (how this ever can be, i dont understand)
  • could you check for a short between pins 37 to 40 on P2 (the mainboard connector faced to the potentiometer side). they are labeled "midi in, midi out, adc14, adc0"

    both adc pins are connected to the switches in the audio jacks, to recognize if a plug is inserted into the jack.
    both midi pins are right next to them.
  • it seems that there is a short between adc0 and adc14. but not between any of them against midi in or out... what to do now?

    ok, i soldered here an there, just where it looked like there could jump some electrons. still no success. 
    however, i went back to 0.21 and now under whatever circumstances it sometimes starts playing when i start the a4. i'll go up to 0.23 and see what happens. seems a bit unreliable at the moment. sometimes it starts sometimes not
  • the short is normal aslong as no plug is inserted into jack 1+2. then both pins are tied to aGND.
    I assume only out 1+2 are affecting midi? not out 3+4?

    could you maybe post a closeup picture of the solder joints for those pins?
    how did you measure for a short?


  • it was happening also with port 3 or 4. didnt matter which port. just when there was plugged an audiocable.
    i'll try to shot something
  • additional info: when i power up the lxr and the midi in is plugged, syncing doesnt work. if i power up with no midi in and attach midi cable after startup, it seems to work every second start. dunno
  • gone up to 0.23 and now it sometimes sync and sometimes not. the audio ports dont affect it anymore, so maybe the oversoldering helped on that. 

    anyhow, directly after powering up my hardware (i have one main switch for all) it doesnt work directly. i need to change bpm up and down to zero. press play sometimes and then it starts (if lucky) could it be that there is some midi data which goes in on startup and confuses the lxr?
  • It may be due to the sync bug I found today. When midi clock signals where received after booting and before pressing play the LXR can freeze. I try to upload a fix in the next half hour (son did not want to sleep today, but is now finally in bed), maybe this will solve your problem.
  • sounds plausible. let's see :)
  • ok - http://sonic-potions.com/public/FIRMWARE.BIN
    try if this version works.

    if not, just for clarification
    MIDI in general was working.
    you only had problems with midi sync?
    or was MIDI completely dead?
  • much better now. still starts not every time, but generally it starts :)

    general midi did work, just syncing didn't
  • Just tried it and the issue seems to be gone. :) Excellent!
  • fyi, the situation when it doesnt work occurs when i press stop on the a4 twice (maybe a transport message)
    all other situations work stable
  • ello said:

    gone up to 0.23 and now it sometimes sync and sometimes not. the audio ports dont affect it anymore, so maybe the oversoldering helped on that. 


    anyhow, directly after powering up my hardware (i have one main switch for all) it doesnt work directly. i need to change bpm up and down to zero. press play sometimes and then it starts (if lucky) could it be that there is some midi data which goes in on startup and confuses the lxr?


    I am experiencing this also - sync rarely works automatically by setting BPM to zero - when it did work it usually needed a few repeat changes of the BPM down to zero and hitting the play + stop buttons a few times. 

    Thinking it might be the midi port solder as the port appeared to be a bit loose and possibly have a bad connection,  I have just removed the LCD which was awkward, but the midi port looks well soldered. I'll put it back together but wanted to check if unreliability with sync has already been fixed in the sampling beta? (I also had the problem with the latest release firmware.)
  • Also the midi sync works when the audio sockets aren't plugged in. 

    Also when I change to the firmware posted above. 

    Took off the front panel, and with audio plugged in, midi sync now works. 

    It seems to be related to pressure on the LCD is causing midi sync to stop. Perhaps it is pushing the midi contacts on the midi socket out of circuit. 
  • my solution is not to put the top left little black screw to hard. as soon as i screw it to the max sync is gone. when i have it a bit loose it works... thats how i am having fun with my lxr. and i can tell you, i am having a lot of fun :) http://www.reverbnation.com/play_now/18842332
  • julian said:

    my solution is not to put the top left little black screw to hard. as soon as i screw it to the max sync is gone. when i have it a bit loose it works... thats how i am having fun with my lxr. and i can tell you, i am having a lot of fun :) http://www.reverbnation.com/play_now/18842332



    I might try either putting some supports beneath the lcd card or better might be cutting a hole in the plexiglass to prevent it from getting pressed down. The case seems to push the LCD down causing this midi error. Too much pressing the lcd starts to mess up the text, so I guess is interfering with the lcd boards pins. I tried putting some thin cardboard beneath the lcd card, in case there were shorts, but that didn't help so I guess it isn't a short between the lcd card circuits and solder on the board beneath ... 
  • yep, i tried that, too.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion