LXR - Doesnt work anymore and shows weird "MIX MIX MIX MIX" values

Hey guys,

my LXR worked really well for over 2 years - really love that Drum Synth!

But then the LXR started to act weird.

It started with no access to these "edit" buttons like LFO MIX. Every time when i pushed these buttons my LCD screen showed "MIX MIX MIX MIX >" values and LED jumped betweeen LFO and MIX Button as well. BUT It was still working for me because i could use everything else and sound was still there.

Then, after a while i couldnt even start the sequencer and the steps cant be enabled. No sound from that point.

I attached a few videos :)

Would be nice if someone could take a look and probably help me.
I would also pay someone to check it precisely. If youre from Cologne Germany, then i would also visit you :D

BTW. I did a real bad solder job, thats why a attached a photo of my soldering.

Thank you in advance and best regards,

Vitali

https://picload.org/view/ddpoiwor/img_3846.jpg.html

https://picload.org/view/ddpoiwoa/img_8751.jpg.html

Comments

  • Hi Vitali,

    I would try to reheat the solder joints. Especially the ones at the rotary encoder, the 74HC165s and the Atmel MCU. And press all those ICs into their sockets. That's all advice I could give.

    Good luck!
    Sebastian

  • have yyou tried reinstalling the firmware?

Sign In or Register to comment.