Step buttons activating wrong steps on new build

Hello. Most of my step buttons are activating the previous step and some are just not working. I have detailed the problems below. I just built my LXR and everything else seems to be functioning well, to my great relief. I have never tried a soldering project of this scope. I assume there are some shorts somewheres, but if you could help advise where they might be, I'd be very grateful!

Step 1: no response
Step 2: activates step 1
Step 3: activates step 2
Step 4: stops the sequencer on first press, nothing on second press, activates step 13 on third press, restarts the sequencer. (weird!)
Step 5: activates step 4
Step 6: activates step 5
Step 7: activates step 6
Step 8: activates step 7
Step 9: activates step 8 or both steps 8 and 9 on successive presses.
Steps 10-16: all working fine.

Thank you!

Comments

  • Solved! I looked around where a previous poster said RR6 resistor had caused a similar problem. I didn't see any soldering shorts, but noticed that a lot of rosin had melted around the area. I wondered if that was conductive, but I figured no harm in cleaning it really good with isopropyl alcohol. After brushing the bottom of the board off really good for a while all the buttons worked perfect! (yay)

Sign In or Register to comment.