Weird symbols on the screen on boot (SD card trouble solved)

edited November 2014 in Troubleshooting
Hey all,

I just finished assembling my new LXR. No problem along the build, everything wen smooth and it is fully operational. Already blown away after 10mn of playing.
Only thing is, I get weird symbols on the screen once in a while (like every 2-3 boot). When this problem appear, the unit appears to be working anyway (chaselight running).
Precision: It is a self sourced unit, but with the programmed Atmega from the shop.



  • Rectification, the unit seems to work anyway when the screen is blocked on these symbols.

  • I had this when I had some bad solder joints on the screen's connector the the PCB and a bad solder joint around the caps near the 20MHz xtal.
  • @matrix12x
    Thanks for your answer, I'll go over the solder joint to check if some looks suspicious to deserve a new solder point.
  • edited November 2014
    I reflowed some points on the connector of the screen and around the 20mhz crystal.
    Still the same issue…
    I saw somewhere on the forum that Julian mentioned that the weird chinese symbols indicate a reboot and that Newhaven displays does not like it… Any way of getting around it?

  • edited November 2014

    Still the same with the boot problem, but I also tried to load some samples on the sd card.
    When I load them via the load samples menu, the sd card become unrecognizable by the LXR and I have to reboot the unit. 
    Precisions: I use a 512mb SD cards formated in FAT16 (FAT32 could not be done for such a small card).
  • I remember having that problem too, I think using another SD and download the firmware one more time is an option.
  • Thanks @mixrasta ;

    So basically I should try to do the firmware update? The AVR was flashed by Julian (I bought it from the shop) so I assumed there is the last firmware on it…
    I will double check the caps around the quartz, but I already did that and could not find any mistakes.
    Thing is, my LXR fully works when it boots normally, even when there is the weird symbols on the screen, I can play with the sequencer etc…

  • As far as I know I had to download the firmware and install it then, and def trz out another card with 32.
  • Will do then!
    I'm currently away from my LXR, but I'll try that and report back next week!
    Thanks again!
  • News:

    I tried to do the firmware update, no luck: It shows a "SD card init error".
    I tried to format the card again and again, and in FAT32, I still have the same issue with loading the samples.
    There is also the screen problem, not sur if these two are linked, but it starts to be a big problem if I want to use my LXR properly…
  • Still the same card or new one? Maybe @Julian knows sth about it...
  • I just bought a new SD card:
    - Firmware update works well
    - Samples uploading works well too

    But the weird symbols on the screen problem is still there. So I guess it is not linked to the firmware or the SD card…

    I really wonder where it comes from, hope somebody could help me on this…

    @mixrasta Try a new SD card, for me it did the trick for the sample upload problem.
  • Wish I could help out with this, but there's not much I can say that would be useful. The 'weird symbols' are a very general failure symptom - I've gotten them plenty of times when making bad software edits (overloading the AVR with too many messages). I've had the 'LXR responds and makes noise but display is locked' with this too. I think it means the display is out of sync with the AVR, but that's just speculation. I will make a sacrifice to the machine god and send good thoughts over on your behalf though!
  • @brendanclarke
    Haha, thanks for your explanations though! Let's hope your gifts to the machine god helps!
  • have you checked your power connector?
    maybe it is jhust a loose contact there.
    Is the LXR still running when you jiggle it a bit?

    as you said the strange symbols normaly indicate a reboot.

    I guess the soldering around the display is ok.

    You mentioned it happens every other boot.
    If once booted correctly, does it still occur after a while, or is the only time it might happen during booting?
  • @julian
    Thanks for your answer.
    I jiggled the power connector, LXR is stills running.
    It never happens when powered, it is always only on boot ( when I insert the power plug).
Sign In or Register to comment.