[SOLVED] Penrose: Trigger locks up module

edited May 2015 in Troubleshooting
I've got a Penrose build from a friend here, which has this little problem... maybe somebody can point us in the right direction to get this fixed.

Basically, the Penrose works fine until you plug in a cable into the TRIGGER IN. Doing this makes it lock up somehow, the first button turns red, the others are green and no incoming voltage is processed. When I unplug the cable again it goes back to working normally.
this behaviour happens also when I just plug a disconnected jack into the TRIGGER IN, which makes me think that there might be a short in the jack socket...

I've checked the components and solder pads... even desoldered most of them... looks all gold to me.
So the question is... what could it be? What could I try?


  • edited May 2015
    Have you soldered the jacks the right way round? The jacks on the left side have to be soldered mirrored to the jacks on the right side (see pictures in the assembly guide).
  • Thanks! I've thought about that as well, but the jacks are all oriented properly as on the PCB marking (with the rounded edges towards the edge of the PCB).

  • as soon as you insert a cable into the trigger in jack, the quantizer will only update the output when a trigger is received on the trigger in jack.

    the module detects the cable being present in the jack and switches modes automatically.

    are the buttons still responding? or does the module completely freeze? in this case a few LEDs should also turn off, because the LEDs are multiplexed.

    Do you have an incoming trigger signal?
  • I don't know what happened... but it seems to work now! I guess it was just a flaky solder spot, I have re-soldered most of the pads twice and now it works...

Sign In or Register to comment.