LXR Kit Build - Voice leds 2, 3, 4 and 5 not working

edited February 2016 in Troubleshooting
Can't believe everything went so well in the build and then the enclosure is becoming the most difficult part to assemble. 

I can't seem to make the top panel fit accordingly with the caps. I managed to put it all together at least 3 times with the caps in different positions and every time theres 3-4 caps that get locked and don't move after the panel is mounted. Every single time those caps are diagonal and it's mostly the Play, 1 and 16 caps. 

Any help is appreciated.

Apparently it was to early for the enclosure, I think I have some problem with voice 2/3/4/5 leds


  • Reflow the solder on your LED's. Not sure about the case and buttons. I found a couple that would stick and a bit of reseating the buttons with blutack fixed it. Didn't see any as angled as your finding. Try putting the buttons in after putting the enclosure together.
  • I just loaded the factory presets and had a run at it and everything seems to be working fine + I can hear all the voice parts working after being sequenced.

    Does anyone know why only voice 2, 3, 4 and 5 leds are not working ? I've tried all modes and even holding shift.

    I've checked all the solder joints and found a small solder leftover in one of the resistor networks which I took care of. I've also resoldered U13(even with the Copy led working) and the leds. I've double checked the resistor network polarities and ICs orientation. I've also checked if they're socketed in the right place but I might check for the 3rd time just in case. 


  • Problem was solved by bending the leds a away from the buttons.

    Regarding the case, I managed to get all the buttons well placed by inserting them only after the whole case was assembled.
Sign In or Register to comment.