Button problems with Penrose

edited February 2016 in Troubleshooting
I have built a Penrose kit and everything seems to work ok except the 6 buttons.
I have checked all the soldering and tested conductivity for the button matrix - all good. I worked out that the buttons are on columns 1 and 2 that don't work. Buttons that have leds on, I cant turn them off
I used atmega328 for the IC but that shouldn't be the problem?
Any ideas?

Comments

  • just so I understand right - the LEDs are all working, but you can't turn those on the pic off. so the buttons dont work.

    I attached a pic with the involved traces highlighted.
    in the end just an AVR pin that multiplexes the buttons for each col.
    did you also check the AVR board or just the front board?

    I think it should work with the 328.
    Self compiled or stock firmware?
    I'm not sure they are binary compatible.

  • I checked both boards. I used the stock firmware. I even tried manual triggering with the jumper cable on the AVR pins. Still nothing. I think the problem is with the 328.
    Found this blog post http://tinkerprojects.blogspot.com.ee/2013/07/arduino-problems-compiling-sketches-for.html

    Now its question, should I order the 168 chip or alter the firmware to suit 328
  • It works. replaced the atmega with 168 and now its working.
  • Hi,

    I have a pretty similar problem : All leds are working good, but I just can't switch off all the steps but 3 of them (see picture).

    Soldering and continuity seems OK. The Atmega168 is the one provided in the kit...

    Can't find out the problem... any suggestion please? Thank you!


  • edited May 27

    I am also having this problem after completing the build from the complete kit using the provided Atmega 168.

    Top three buttons in column 1 (white keys) turn on and off, bottom three buttons in column 2 (black keys) turn on and off. The two top buttons on each column sometimes alternate between green and red and when I hit the top button in column one it triggers the gate out led, but does not seem to send a gate or trigger signal.

    have checked continuity and resistor values, everything seems to be in place...

    wanted to add that the module will go into firmware update mode and I have fed it the most recent firmware file, but it goes right back to this behaviour

Sign In or Register to comment.