help needed, knob not working...

edited February 2016 in General
Hello all.
I am trying to build lxr, but face some problems.

At my first build of it, all was working. I had to change the pots. After desoldering and putting news one in place, the left one was not covering the full range ( it went from 0 to Around 100, sometime 90, Sometime, 105, but never to 128, and was flickering between value +1/value -1, causing jump (saying it jump from the value of the patch and the real position of the knob, it dectect a knob movement due to these flickering..)

So i tried to rework the soldering joint.

Since this, the knob dont work at all anymore.

Lxr being unplugged, i probe the left and right metal pin of the knobs, each pot as one connected with 5 v, one connected with GND.

I tried to probe the central pin tweaking the knobs the same time. The 3 knobs that are working output the same resistance range,  not 0 10k because i think it's bad to probe in builded circuit like that, but the same value same range between them

The non working pot is showing different value, different range, different comportement when tweaked

From what i can undertand ( may certaily be wrong) the pots are directly connected to the at mega.

Is ok to think the knob is faulty here ( i might have overheated one of the pin)? Or might it be the at mega???

Any help would be greatly appreciated, and if someone can sell me a knob and a bit of desolder braid, that would be great.


  • No one can give à hint if its more knob or atmega fault??
  • I am really sorry that you have so much trouble with your LXR.
    From your discription, it is most likely a faulty potentiometer/knob.
  • Thanks for your answer. i will order one and change it . hope it will be ok this time.
  • Thanks for your answer, will try to change it.
  • floflo
    edited February 2016
    fixed was the knob, thanks
Sign In or Register to comment.