Problems updating Firmware - Error Message "F"

edited February 2016 in Troubleshooting
Hi there.
Sorry if I'm asking something that has already been discussed. Have tried the forum search and google, but could not find what i was looking for.

I have firmware 0.34 on my LXR and wanted to try the latest version. When doing the update it goes to bootloader 1.2, then it just shows the letter F..
And randomly, rows of leds light up and stay lit. Mostly just the letter F though. Also tried with Brendan Clarkes firmware, and now I have the firmware file for version 0.34 on the card, but if I try to reload the firmware it gives the same result. I have previously updated the firmware from a earlier version than 0.34 successfully. 

The reason i wanted to upgrade the firmware was because I could not seem to sequence my waldorf rocket properly with the lxr, and thought new firmware might do the trick. (It sends notes on to the rocket, but no note off? The rocket stays triggered all the time while the sequencer is running.) I am pretty sure I have correct txf settings..

cheers, Vegar


  • edited February 2016
    Try reformatting the SD card or try a different card? Just 'F' isn't an error code I'm aware of, but it might be trying to display 'File System Error' and crashing before it can get through that. If that doesn't work, check the connections to the 644-20 and swap that for a known good one if you can.

    I think in my firmware if you set a step with velocity zero, it also sends a MIDI note off for that step/channel/note. I did it a while ago and I don't do a whole lot of external sequencing. It's a bit cumbersome because it leaves it up to you to make sure that notes that get turned on also get turned off. I think you can record into the sequencer from a keyboard, too, but the same rule applies. Of course, this is nice in that it lets you use a mono track to play pseudo-polyphonically, but it can be headache-inducing to actually bang this into the sequencer. And switching patterns on the fly can easily break this in a bad way. In the end, it would make more sense to have a 'length' parameter per step.

    Rocket is nice :) Rather good for running things through the filter, though the noise floor is a little high. Between that and the Evolver I feel pretty well covered for analog filtering. Maybe if someone made made an SEM filter box that didn't need a modular rig... could just get a pro2 I guess!
  • Hi, thanks for your reply!
    Will try reformatting and/or swapping cards. I can save kits and stuff to the card tho, it reads fine it seems, but I cant seem to do firmware upgrade. Maybe something has come loose inside. Have not really been in there since i built it, and at that time i could do firmware upgrades. Sadly I don't own a soldering kit anymore, but hey I need to get one anyway so this is probably the push i need to go get one. Might come back to ask advice on that, the LXR is the only thing I've soldered except the odd cable.. But I do want to get into DIY eurorack modular...

    Note length would probably work well! Is that possible to include in another firmware u think? 
    The Rocket is cool, it def has its own character. But money is really scarce in this household so I might have to let it go since my Korg Zero4 mixer just started acting up. Seems I need a new mixer.. I think it got to do with the power-supply, it sometimes start making noise on all the channels. Sad, because it is such a versatile piece of kit! It has switchable power-supply, and google tells me they can be swapped for AC ones, but this is out of my league still.. Tips welcome! ;)

    Will try the LXR a bit later with a reformatted card and post the result back on here.

    Have a continuous lovely morning! :)

  • Just had time to reformat that sd card, and still gettting the same F... Does this mean I need to do surgery on my machine? Have had a look at the build manual again and can not see 644-20 mentioned anywhere.. I think I am in need of a some detailed guiding here. 

    Anyone care to post a pic of where I should be looking? As I explained in my first post the LXR is my first and only build, and I built it two years ago, so my memory has faded! I did however have a electronic engineer with over 40 years of experience help me, and overlook my work at the time. He was happy with all my solders etc, but I guess these connections might come loose somehow. 

    I built it while living in South Africa, and it has now travelled with me back to the north so maybe it got some bad handling in transit, i'm not sure. It works well, except maybe the push-encoder seem to wobble a little between the numbers sometimes. Also LED 3 is not working, but I think that should not have anything to do with the SD-card. Seems I have to go get a soldering iron! Hope to get it updated asap! :)

    I can save kits and performances to the card, it is in Fat32 format, 1gb... Have yet to try a different card tho, as I don't have one. I will see if I can find one and try, but my gut tells me it's not the card..
  • Sorry for this dumb question, but do you have the file 'firmware.bin' with a size of about 240k in your root directory?
  • Hi Möbius, thanks for the reply. 
    Yes I have FIRMWARE.BIN in the root directory. I have tried with the factory sd-card settings, and with the 0.35 firmware.bin and also brendan clarkes firmware.bin. I have tried removing the additional kits and patterns that were stored on there by me. So it's seems to be a bad solder then?
  • Possibly. I meant the Atmega - it is a 644-20 model. You might give Julian a shout and see if he can swap one with you. If you have a multimeter and can test the connections to the microcontroller or can see something wrong, correct it, but I wouldn't do any invasive re-soldering until you've eliminated things that are easier to swap.
  • Hi Brendan, just opened up and the Atmega says 644A PU 1231. will post a pic just now. Unfortunately I dont have a multimeter.
  • Here's a pic of the Atmega
  • loading with 0.34, i hold down the rotarypush , goes into bootloader 1.2 , then says f..
  • Got to borrow a multimeter now! Gonna check the build-guide and see if I can test the connection. Totally noob tho, as you can probably tell so if anyone once again care to just explain that would be great! Will check that building manual though!
  • Just had a read through the guide, and could not find how to check the connections to the microcontroller. I checked that the volt between +5V and GND measured correctly, it did. I bought the LXR as a complete kit from Julian, so the Atmega should be the correct one. How do I proceed on measuring the connections to the microcontroller? Feeling I'm gettting somewhere at least! Also now LED 3 works after pushing it ever so slightly :)
  • Hmm... yeah, if wiggling one of the LED's gets it to work, that might indicate that some of the solder points might need a reflow. If the LXR works normally but won't accept a new firmware, I *think* that means that one of the pins associated with resetting the atmega, or getting SD card status is wonky. That means (most likely) either one of the solder points on the atmegas's socket, or one of the points on the header strips the mainboard plugs into.

    If it were me, I'd unseat the atmega, remove the mainboard, and test each of the socket and header points for continuity to the board. You could also just try reflowing anything that looks visually suspect, but I can't tell anything about the solder points from those pictures.

    If you look here, the points I would pay attention to first would be 41, 43, 45, 48 on the headers connecting to the mainboard, then look at 1,3,5,7,9,11,17,19, then check the associated pins on the atmega socket - 5,6,7,8,14,15,16,17.
  • Thanks! I will have a look at this when I get time. I will probably ask for some more guidance along the way, and post some better pics of my solder-points. again, thanks for helping out!
  • hey guys, when i´m trying to update the LXR firmware, i´m getting a "success, please reboot (old firmware)" / notif at the end (nothing specific with the bc firmware, seems to work too). after reboot though, the display shows cryptic signs only, that wont change. the machine works, the display doesnt. 
    couldnt manage to getting it back to the old (working) state. 
Sign In or Register to comment.