LXR Display problem [solved]

edited July 2016 in Troubleshooting

I just built my first LXR and I have a small problem with my oled display.
First of all it worked fine, I've tested it with 600mA and 1A PSU's but then randomly came the problem
When booting up the LXR the display randomly doesn't reset or clear itself and the text Sonic Potions LXR V0.37 appears and just before it goes to coa fin wav screen "SON" appears on 2nd line of the display all the way to the right.
After that the display shows duplicate lines, but when I turn pots the other line shows different readings on the value. I've checked the soldering and it looks good. Some joints I reflowed.
The machine works just fine but it's impossible to change modes etc. All the leds runs fine also, buttons do what they should.
If i boot to firmware update, the screen works fine, when it says reboot the machine and I do it, the problem persists.
I can't reproduce the problem, it just randomly comes and stays for like 20 reboots and after that the screen works again fine.
Also with brendanclarke's custom fw and the one inside SdCardimage. All produces the problem.

Anyone have any ideas what to do ? :)

Thank you in advance.


I changed the SD card to another and used better quality PSU with 1A. The 9V 600mA PSU which I have might be a cheap one and the specs don't be accurate.


  • Hello! 

    I built my LXR and it worked like charms for about 3 months. But now i'm facing the same issues.

    Every time i boot the LXR, the display shows "LXR V0.37", do not restart and turn into "LXR V0.37s". After it shows duplicate lines or totally messed up menu pages. 
    Menu, audio and chaselight are working good.

    I tried to change PSU, SD card and firmware... Nothing works, however when i'm booting a new firmware the screen seems to work perfectly.

    If someone have an idea of what it could be ?

    @monkeyphonic It is still working for you ? :)

    Thank you
  • @Knutt My problems went away after changing the PSU and SD-card and hasn't come back, have you checked that the atmega is seated properly ? I think this IC handles the screen, not sure if correct thou :)
  • I checked but the atmega seems fine. Voltage is also 4.9V as expected. Maybe a soldering problem but where ? :(
Sign In or Register to comment.