Custom Firmware - new features

15678911»

Comments

  • @leterell there was some head nodding. shame it was badly attended, strange business promotion!
    brendanclarke i'm guessing you're busy!, any update on the next pattern bug. Got another gig tomorrow, i'm loading 'all' files and quickly checking the pattern nexts with shift!
    Cheers

  • edited December 2016
    @smilan - don't use EG positioning as the only method of triggering a sound. You need to have at least 1 real trigger in the pattern, otherwise sound parameters will never update.


    Right now I don't have time to look at bugs, get back to me in 6 months when the PhD is in :) If someone wants to help out, I'm willing to look at anything pushed to me in github.

    Side note - if anyone wants to see what I do in the "dayjob," this was just published ...

    http://www.nature.com/articles/ncomms13705
  • lazenbleep: cool gig!!! Really liked it, what was your setup there?
  • @brendan, I'll wait! 
    @papernoise LXR, ANUSHRI, OP1
  • @brendanclarke, fellow physicist here although I'm in a totally different field (thermoacoustics). Read the paper and it looks like a fun project. Good luck with the thesis. Writing mine was a brutal experience.
  • @lazenbleep a relatively minimalistic setup, it sounded like more... which is always a good thing!
  • @papernoise
    I forgot! OTO Bim on aux1 and MFDrive>BossCS2 on aux2. This adds moisture and fat respectively
  • i think I've found a bug in the channel management.

    I wanted to set drums 1, 2, 3 to channels 10,11,12 and leave everything else on channel 10. That way I can play chromatically from my Midibox without resorting to CC twiddling. So I set the channels like above and set Note = Any on drums 1-3. All good.

    If I set a beat going on the channel 10 voices (snare, hihat etc) and then press "Voice" and select one of the drums set to note ANY, then they play the channel 10 beats, despite being set to a different channel.

    This is coming from the Global Channel (which I'd left at 10). So the individual voices listen and respond on both the Global channel AND the voice channel. I have to set the global to 16 (basically wasting a channel) to get what I want.
  • edited December 2016

    @smilan - don't use EG positioning as the only method of triggering a sound. You need to have at least 1 real trigger in the pattern, otherwise sound parameters will never update.


    Right now I don't have time to look at bugs, get back to me in 6 months when the PhD is in :) If someone wants to help out, I'm willing to look at anything pushed to me in github.

    Side note - if anyone wants to see what I do in the "dayjob," this was just published ...

    http://www.nature.com/articles/ncomms13705
    Good luck with your PhD. Interesting day job :)

    I really hope you will be able to fix this bugs, lxr loading wrong sounds and next pattern bug is my nightmare. I am really sorry to say that I am thinking to go machindrum, i would really be nervous performing in front of audience with this bugs, i would miss the sound of lxr and probability steps, but get stability in return and better pattern and sound organisation. So i really really do hope. 


  • edited January 2017
    to anyone that knows, does the original firmware has also next pattern bug or not? 

    edit: yes it does :-/

    Way is it not solved buy now is unknown ?
     I really like this machine but I think this bug should be fixed. It in your best interest, you can't have this great machine with this bug. It is not how it should be ;)
  • Hello brendan,

    Is it possible for you to program the lxr that the running sequencer has some random step jumping? I.e. The machine running thru rhe 16 steps an repeat/ go back or jump to the next event. So if step 3 is in this mode it will will run back to the last event in the sequencer or jump from 3 to the next event.

    Thx a lot
  • question about bootloader/ OS update:

    tried updating to your recent FIRMWARE.BIN.

    On the screen shows:

    "Bootloader V 1.1"
    and then "firmware error"

    I saw on your homepage a Bootloader V 1.2
    do I need this to get the latest firmware going?
    If yes, how do I update the bootloader?


    thanks a lot


    (what I did was copying the FIRMWARE.BIN to SD card, then hold encoder on power up)
  • found out: had to format the SD Card to FAT32 instead of just FAT
    no it works :-)
  • How does one format the original sd card to FAT32? Does it overwrite the original files?

  • @ammanuel said:
    How does one format the original sd card to FAT32? Does it overwrite the original files?

    Same procedure as regular HD (Mac or Win). Contents will be erased so make backup of SD-card first if needed.

  • Is it normal that 0.37 isn’t compatible with Bastl’s 60 knobs?
  • hello, is anyone there?... :)
    lately, my LXR keeps stopping (Brendan Clarke firmware). it's playing as normal, suddenly all control is lost, leds go blind, but the music keeps playing. need to turn on/off. any idea why, and how to solve? anyone tried the BC beta?
    will ask in "Troubleshooting" too, but I thought I'd try here, as I use the Brendan Clarke fw.

  • edited 1:13AM

    I did have a lot of crashes like that on one version of the firmware and had to roll back a few features.

    Back up your card and try the firmware up at brendanclarke.com/files/LXR/FIRMWARE.bin currently. It's the one I've been using lately and that kind of crash hasn't happened in a long time. Let me know if it keeps happening and under what conditions, I may get a little time to work on it in the next couple months.

    Hope that helps!

Sign In or Register to comment.